Error actualizar Fedora

Error actualizar Fedora

En este apartado de blog explicaremos varios problemas que pueden suceder cuando queremos actualizar el sistema Fedora es por eso que hemos titulado a esta entrada de blog Error Actualizar Fedora.

Recuerda que puedes descargar la última versión de Fedora de forma gratuita en la página oficial de Fedora.

La idea de esta entrada es que puedas ver los errores que pueden aparecerte a la hora de actualizar el sistema operativo Fedora y además puedas solucionarlos.

Al intentar actualizar a Fedora 30 (o versiones superiores), es posible que aparezcan conflictos entre varios subpaquetes Package-x-generic-16.pngfedora-release. Si esto ocurre, le recomendamos que elimine uno de los paquetes en conflicto para desbloquear la actualización. Deje instalado el paquete que más se acerque a la forma en que desea que el sistema se identifique, el que más se acerque a su uso principal del sistema.

Error actualizar Fedora – Problemas generados por el Hardware de Fedora

Problemas relacionados con el adaptador de Wifi

Múltiples usuarios de adaptadores de red inalámbricos soportados por el controlador propietario broadcom-wl han reportado que no funciona de manera confiable en Fedora 30. TENGA EN CUENTA que Fedora no proporciona ni da soporte a este controlador propietario; estamos proporcionando esta nota sólo como una cortesía ya que somos conscientes de que muchas personas adquieren el controlador de un tercero y lo utilizan en Fedora.

El problema parece ser que una nueva característica en Package-x-generic-16.pngwpa_supplicant que fue activada en Fedora 30 confunde al controlador broadcom-wl. Como el controlador no es de código abierto, no podemos proporcionar una versión fija del mismo, y no vamos a desactivar una característica útil de Package-x-generic-16.pngwpa-supplicant sólo para hacer que un controlador propietario funcione correctamente.

Para ayudar a la gente con dispositivos afectados, Davide Caratti está proporcionando reconstrucciones no oficiales de Package-x-generic-16.pngwpa_supplicant con la función en cuestión desactivada. Puedes habilitar su repositorio COPR ejecutando sudo dnf copr enable dcaratti/wpa_supplicant, y luego la actualización de tu sistema debería instalar su reconstrucción, si está actualmente actualizada en comparación con la versión en los repositorios oficiales. Con esta reconstrucción instalada, el adaptador inalámbrico debería funcionar de forma fiable.

Problemas relacionados con el software de Fedora

Conflictos entre paquetes fedora-release al instalar grupos de paquetes

Al intentar instalar grupos de paquetes, puede encontrarse con un conflicto entre diferentes subpaquetes Package-x-generic-16.pngfedora-release. Esto puede ocurrir, por ejemplo, si instala el grupo de paquetes servidor-producto o varios de los grupos de escritorio después de la instalación inicial del sistema. Este error tendría un aspecto similar al siguiente:

Problem: problem with installed package fedora-release-workstation-30-0.24.noarch
– package fedora-release-workstation-30-0.24.noarch conflicts with system-release provided by fedora-release-matecompiz-30-0.25.noarch
– package fedora-release-matecompiz-30-0.25.noarch conflicts with system-release provided by fedora-release-workstation-30-0.24.noarch
– package fedora-release-workstation-30-0.25.noarch conflicts with system-release provided by fedora-release-matecompiz-30-0.25.noarch
– package fedora-release-matecompiz-30-0.25.noarch conflicts with system-release provided by fedora-release-workstation-30-0.25.noarch
– conflicting requests
(try to add ‘–allowerasing’ to command line to replace conflicting packages or ‘–skip-broken’ to skip uninstallable packages)

Pero con los nombres de los paquetes dependiendo del paquete que ya tiene instalado, y el paquete que viene con el grupo que está tratando de instalar.

Opciones para resolver el problema comentado

Tienes cuatro opciones para resolver este problema. En cada caso utilizamos los nombres de los paquetes del ejemplo anterior; obviamente debe modificarlos para que coincidan con los nombres de los paquetes que realmente están involucrados en el conflicto en su sistema.

  • RECOMENDADO Pasar —excludepkg fedora-release-matecompiz a DNF. Esto eliminará sólo este paquete de la transacción y permitirá que el resto del grupo se resuelva normalmente. Esta opción mantendrá la «identidad» de su sistema a lo que era desde la instalación inicial.
  • Pa se --excludepkg fedora-release-workstation a DNF. Esto eliminará sólo este paquete de la transacción y permitirá que el resto del grupo se resuelva normalmente. Esta opción cambiará la identidad de su sistema de manera que ahora se reportará como un sistema MATE Compiz en lugar de uno de estación de trabajo.
  • Pase --skip-broken. Esto es similar a pasar --excludepkg fedora-release-matecompiz excepto que también omitirá cualquier otro conflicto potencial que pueda resultar en una instalación de grupo incompleta. Asegúrese de examinar cuidadosamente el resumen de la transacción antes de proceder. Esta opción mantendrá la «identidad» de su sistema a lo que era desde la instalación inicial.
  • Pase --allowerasing. Esto es similar a pasar --excludepkg fedora-release-workstation excepto que también puede resultar en el reemplazo de otros paquetes en su sistema inesperadamente. Asegúrese de examinar cuidadosamente el resumen de la operación antes de proceder. Esta opción cambiará la identidad de su sistema de manera que ahora se reportará como un sistema MATE Compiz en lugar de uno de estación de trabajo.

Error actualizar Fedora – Problemas al intentar instalar Eclipse o actualizar un sistema con Eclipse instalado

Varios usuarios han reportado que al intentar instalar Eclipse y/o paquetes relacionados, o al actualizar un sistema con Eclipse instalado a Fedora 30, falla con varios errores de dependencia. Esto parece estar causado por desajustes entre los paquetes de algunos módulos y los paquetes de los repositorios no modulares. Los empaquetadores pertinentes están trabajando para investigar y resolver estos problemas lo antes posible. Por favor, siga el informe de errores para obtener detalles específicos y posibles soluciones.
Error actualizar Fedora

El paquete repoview no puede ser instalado

El paquete Package-x-generic-16.pngrepoview en Fedora 30 no es instalable. Esto se debe a que una de sus dependencias (python2-kid) se retiró por falta de mantenimiento y se dejó fuera de Fedora 30.

ERROR ACTUALIZAR FEDORA – Problema en el disco de arranque

Si al actualizar el sistema de Fedora aparece un problema relacionado con el disco de arranque o el grub también podrás solucionarlo. No obstante, para solucionarlo de forma rápida te recomendamos que utilices una herramienta externa. La herramienta es Boot Repair y sirve reparar los grub o los discos de arranque de cualquier sistema. Puedes descargalo gratuitamente en BootRepair.es

Te dejamos un tutorial para que puedes utilizar Boot Repair para reparar el disco de arranque de tu máquina: Reparar el GRUB de Linux con Boot Repair
not add ppa boot repair

Un saludo y espero que con esto podáis resolver varios problemas que tengáis durante las actualizaciones de Fedora.

1 comentario en «Error actualizar Fedora»

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

*